sed and find

Armin Theissen
Thu Nov 16 09:21:00 GMT 2000


I'm new to this list and to cygwin in general, and I have a problem 
which I cannot find discussed anywhere on the faq or mailing list 

its about the commands 'sed' and 'find'. I used the cygwin_b20 and 
their sed and find therein with no problems, but the obviously 
different sed and find in cygwin 1.1.4 gives me compile errors. 

sed complains about unterminated 's' commands, as in 
  sed "s/bla/blubb/"
which can there be solved by removing the quotation marks. However, 
in order to expand complicated s/// expressions when compiling under 
non windows plattforms, I cannot simply remove them all in the (huge) 
code.  Is there a way to make sed in cygwin 1.1.4 understand the 
quotation marks? 

Another cause for headaches is 'find' which just won't find anything but 
complains about unfound files/directories - as it seems in the path 
where to find. I assume there is a problem with slashes and backslashes. 
Again, the find of cygwin b20 worked. 

Is there any chance to get these working without copying over the old 
versions? Or is this eventually a known bug for which there is somewhere 
here a solution? 

I hope there is. Otherwise: will cygwin_b20 still be available in the 



-----------------------------------------------------------------------                    phone +353 1 819 9080

Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list