'find' quirkiness

Tom Trelvik ttt@po.cwru.edu
Thu Nov 9 02:36:00 GMT 2000


	Actually, Jörg, I did try that first, unfortunately to no avail.  A
`find /cygdrive/c -print` returned the same unexpected results as `find
c: -print`.  Likewise, `find /cygdrive/c/winnt -print` yields the same
expected results as `find c:/winnt -print`.  And it doesn't seem to care
if I include a trailing '/' after any of these paths to be searched.

	Per the FAQ's advice, I tried the following, and it certainly appears
to be using the proper version of find.  Out of curiosity, what does the
"is hashed" mean?

 ~ $ type find
find is hashed (/bin/find)
 ~ $ which find
/usr/bin/find

	Also per suggestion in the FAQ, I mounted the c: drive (on /c), and
then tried again `find /c -print` and again saw it return /c/WINNT but
nothing from within that folder, and again, specifying that folder
returns all of its contents just fine.

	Oh, and on a sidenote, I've noticed in the FAQ that it says that the
"which" command is not available with cygwin.  I was dissappointed to
learn this when I first installed (as I didn't know, until now, to try
'type [command]', so I went to freshmeat.net, found and downloaded a
tarball for which.  A simple 'tar -xzvf [tarball name]', './configure',
'make', 'make install' worked just fine for me to get it working.  So if
anybody else is interested, it's certainly possible.  Sorry if that's
old news to everybody else.

	Anyway, thanks again for all of the help!

Tom

--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list