fork_copy error

Earnie Boyd
Tue Mar 21 05:13:00 GMT 2000

--- Larry Rau <> wrote:
> On win98 se2 with cygwin version:
> BASH.EXE-2.02$ uname -a
> CYGWIN_98-4.10 POWERPLAY 1.1.0(0.18/3/2) 2000-03-20 00:14:57 i586 unknown
> I get the following error during a large make (around 5k files
> don't know where it fails.. bunch of javac launches)
> 0 [main] MAKE 1003 fork_copy: user/cygwin data pass 2 failed, 0x4580000..0
> x47E5000, done 0, Win32 error 8
> make: vfork: No more processes
> Once this occurs if I re-run the make it will process some more
> files and then give the same error. Eventually make will just fail
> to run anymore compiles (in this case always javac).  The only way
> to cure it is to reboot win98.  Exiting all bash shell's is not 
> enough.  The rest of win98 appears to function ok (well normal) as
> far as I can tell.
> Does anyone else experience this?  On smaller makes running gcc I
> have not had a problem.  

It's happened in the past.  Have you tried the using the -j switch for make to
give it the maximum number of jobs it can start?  Don't know if it will help.

> Is Win2k much more stable for using cygwin?  I've been thinking of
> upgrading as I think my main tools will run on win2k: gcc,cygwin,wincvs.

I'm using WinNT and Win2k is it's replacement.  It's been reported stable for
cygwin on this list.

   Earnie Boyd: < >
            __Cygwin: POSIX on Windows__
Cygwin Newbies: < >
           __Minimalist GNU for Windows__
  Mingw32 List: < >
    Mingw Home: < >

Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.

Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list