rxvt and tcsh

Hans Weber weberh@cs.unc.edu
Wed Jun 14 12:12:00 GMT 2000

rxvt 2.6.2 (or 2.7.2) for win32 seems to behave fairly well with bash,
but not so well with tcsh (vinschen's version).  I have the following

SET PATH=.;d:\cygwin\bin;d:\cygwin\usr\bin;d:\cygwin\usr\local\bin;%PATH%
REM tcsh
rxvt-2.6.2.exe -fn "Lucida Console-12" -e bash

which works fine with bash, but when i replace bash with tcsh, i run into
problems immediately.  For instance, if, after starting up, I resize
the window, then type 'ls', the prompt never comes back.  Also, each time I
do a resize, the prompt is printed again (ie, an extra time).

I am running on a win98se machine with cygwin 1.1.2, tcsh 6.08, and rxvt 2.6.2
(and have tried 2.7.2).  Tcsh seems to work quite well in the dos box, but
not in rxvt.

Have others run into this problem, or does everyone just use bash?


(btw, the problem seems win98 specific since I don't encounter it on my nt 4.0

Hans Weber                                                    weberh@cs.unc.edu
CB #3175, Sitterson Hall, Department of Computer Science  Voice (919) 962-1928
Univ. of North Carolina, Chapel Hill, NC  27599-3175      Fax   (919) 962-1799

Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com

More information about the Cygwin mailing list