Make, and VPATH's

Neil Clayton
Tue Jun 13 21:54:00 GMT 2000

I'm attempting to compile some java code via make, and am running into some
difficulty when I attempt to split the source and class file locations.

I'm using jdeps to generate parts of the makefile, here is some partial
output from jdeps. (BTW: source is located in /src/src and classes are in



class: /src/classes/nz/co/kbgroup/cs/guifw/model/AggregateChange.class

: /src/src/nz/co/kbgroup/cs/activeobject/server/general/




JAVACOMPILE is set to: jikes -g -nowarn -d /src/classes

Make runs OK, and everything appears to work, but when I run make again, it
recompiles everything from scratch. It's as though it never see's/finds the
target (the .class files). If I change back to using the same dir for both
source and class files, it works.

I've tried using VPATH = /src/src:/src/classes but that does not help (and
I'm not sure I've understood it anyway!).
I've lookup up the GNU doco on make, and it says the target is built if
either make can't find the target, or it's out of date compared to the
source files. I'm assuming here that it can't find the target for some

The only thing I can think of is that it's got something to do with me using
full paths in the rules.

Anyone got any ideas on this?


KB Group Ltd - eBusiness Solutions 
Neil Clayton
Solutions Developer 
Ph +64 4 384 5680, Fax +64 4 384 5681
PO Box 9231, Wellington, New Zealand 
KB Group Website < > 

The information contained in this mail message is confidential 
and may also be legally privileged. If you are not the intended 
recipient, please note that any use, dissemination, further 
distribution, or reproduction of this message in any form what 
so ever, is strictly prohibited.  If the mail is in error, please 
notify me by return E-mail, delete your copy of the message, 
and accept my apologies for any inconvenience caused.

Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list