Where can I get Cygwin 20.1b?

MarketLogix mlx@mlx.com
Tue Jun 13 18:25:00 GMT 2000


I don't know where the "b" came from, not at all familiar w/that.

Isn't this just what's known as the old full.exe, circa 9801203 ?

This is what I still use (with egcs 1.1.1 release) and I'm
still rolling along just fine.

Here's my uname: 20.1 (0.3/1/1) 1998-12-3

Its good reliable stuff, I'm still hiding behind it.

bisk


Begin forwarded message:

Mailing-List: contact cygwin-help@sourceware.cygnus.com; run by ezmlm
List-Subscribe: < mailto:cygwin-subscribe@sourceware.cygnus.com >
List-Archive: < http://sourceware.cygnus.com/ml/cygwin/ >
List-Post: < mailto:cygwin@sourceware.cygnus.com >
List-Help: < mailto:cygwin-help@sourceware.cygnus.com >,  
< http://sourceware.cygnus.com/ml/#faqs >
Sender: cygwin-owner@sourceware.cygnus.com
Delivered-To: mailing list cygwin@sourceware.cygnus.com
X-Originating-IP: [160.149.21.20]
From: "Bradley Smith" <brad2010@hotmail.com>
To: cygwin@sourceware.cygnus.com
Subject: Where can I get Cygwin 20.1b?
Date: Tue, 13 Jun 2000 15:53:57 PDT

I'm trying to make a ".dll" so that I can run the JNI and interface some C++ 
code with some Java code...

Here is the site I found some code :
http://www.xraylith.wisc.edu/~khan/software/gnu-win32/dllhelpers.html

That demonstrates how this works.   HERE IS MY PROBLEM: When I run the
already compiled code examples that come with the "dll helpers from that web 
site",  it works FINE! which tells me that the .dll that *someone* created
is valid.   Yet when *I* try to compile the code, and create the .dll
myself; it fails.   I believe it's because I don't have the right version of 
Cygwin (which it recommends 20.1b  or better)   and therefore I don't have
the right version of egcs (which is recommended 1.1.1) where my version
shows I have 1.1

I'm told that Cygwin 20.1b is the version I need to be running because it
contains egcs 1.1.1 and apparently I dont' have that version because when I
do "gcc -v" it tells me I have egcs 1.1   not  egcs 1.1.1

I've downloaded the  Cygwin 20b apparently (from the "latest" release
directory on cygwin's ftp site and installed it...   but when I do  "uname
-a"  it tells me I have 20.1....    I'm so confused...  since even during
the Install process it tells me I am installing just version 20b.

I tried to installed egcs separately (newest version) thinking that would
fix my problem that I'm having  (lack of egcs version 1.1.1); but I can't
seem to get that installed to see if that fixes my problem.

So I'm thinking that if I just got the full version of cygwin (the 20.1b
version) everything should work fine..


Can someone please help me find the full version of 20.1 ???
I tried going to the Cygwin ftp site, and downloading what it says is the
"latest".. but when I install it   it only says it's version 20.   I even
tried downloading the  ".dll" upgrade that "supposedly" upgrades me from 20  
to 20.1    but that seems to make no difference in the compile results
problem that I'm having..

Help Please!!

thanks

-Brian

--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list