<defunct> processes under Win9x...

Ken Coleman kcoleman@yahoo.com
Mon Jun 5 13:27:00 GMT 2000

I understand that this is difficult to debug from an
strace log.  I was just hoping that the new
information would spark some "a-ha!" in you that would
make the fix easy :).  I'll be working on it more
tonight, but for now I have a little more information.

I'm attempting to attach to the process, and all I get
is "Can't attach to process.".  I've attempted to run
"gdb filename process-id", and done it within GDB with
the appropriate commands.

One other minor piece of the puzzle - Cygwin refuses
to kill the <defunct> process ID.  When I attempt
this, it says:

 1000  -1  13:22:30
 1001   0  13:22:31 /usr/bin/BASH.EXE
 1011   0  13:22:58 /USR/LOCAL/APACHE/BIN/HTTPD.EXE
 1013   0  13:23:04 <defunct>
 1014   0  13:23:06 /usr/bin/PS.EXE
/usr/local/apache/bin $ kill -9 1013
bash: kill: (1013) - No such pid
/usr/local/apache/bin $ 

I have also tried attaching to other processes, and it
gives me the same error.

Any thoughts?
- Ken.


I'm sorry this is really to difficult to debug from an
strace log.

The symptom of wait_subproc looping is not abnormal. 
It's what happens when a program has started a sub
process.  The wait_subproc thread disappears when the
program exits.  That's the only time it goes away.

You are going to have to do quite a bit more
debugging, unfortunately. If you have an actual
process that is not going away then you should
be able to attach to it with gdb.


Do You Yahoo!?
Yahoo! Photos -- now, 100 FREE prints!

Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com

More information about the Cygwin mailing list