building cygwin1.dll

Mumit Khan khan@NanoTech.Wisc.EDU
Tue Jan 11 14:51:00 GMT 2000

Alexey Voinov <> writes:
> Hello,
>    Tried to build cygwin1.dll myself.
> Got:
> fhandler.h: In method `select_record::select_record(fhandler_base * = 0)':
> fhandler.h:759: implicit declaration of function `int __builtin_memset(...)'
> if I comment out #define memset __builtin_memset in winsup.h
> all compiles but I got link time error in ntea.o.
> I use:
> $ uname -a
> CYGWIN_98-4.10 VOINS 1.1.0(0.16/3/2) 2000-01-06 12:55:43 i586 unknown
> $ gcc --version
> 2.95.2
> Also tried gcc 2.95... same result.

You should browse the cygwin-developers list if you're building the 
snapshots (as opposed to say using the binary installations provided 
with each snapshot). This problem has been fixed since. for email archives.

You should wait for the next snapshot which fixes a configuration goof
when installing mingw headers bundled with winsup.


Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list