SSH and Cygwin 1.1.6

Erdely, Michael mike@erdelynet.com
Fri Dec 8 06:56:00 GMT 2000


I did read the read me.  Every time before when I tried to connect when
running sshd -d from a command line and tried to use password
authentication, I get:
    erdelym@localhost's password:
    debug: authentications that can continue: publickey,password
    debug: next auth method to try is password
    Permission denied, please try again.
    erdelym@localhost's password:
And, I didn't experience the problems when I ran SSHD under it's own
service.  Only when running with inetd.  So running it from the command
prompt isn't helping (it's, in essense, the same thing).

Is there a way to get debug output from sshd -i running under inetd?

-ME

----- Original Message -----
From: "Corinna Vinschen" <cygwin@cygwin.com>
To: <cygwin@cygwin.com>
Sent: Friday, December 08, 2000 9:24 AM
Subject: Re: SSH and Cygwin 1.1.6


On Friday 08 December 2000 15:06, Erdely, Michael wrote:
> I'm trying that now.  But it's my understanding that if you run sshd
> as someone other than "system", you can't use password
> authentication.  Is that incorrect?
>
> To get around that, I'm trying to set up an "sshd2" that uses RSA
> Authentication so that I can run sshd -d from a prompt.

What do you mean by that??? Just start sshd on the command line
and that's it!

> Or is my thought process wrong here?

I fear, yes. Did you read /usr/doc/Cygwin/openssh-2.3.0p1.README?
Did you have a look into the ssh man pages?

To be allowed to change the user context isn't bound to `system'
but to the user rights which are attached to users/groups in the
NT user manager resp. W2K's Security Policy MMC-Snap in.

On the other hand, starting sshd under your own account and then
using RSA/DSA authentication is way more comfortable ;-)

Corinna

--
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                                mailto:cygwin@cygwin.com
Red Hat, Inc.
mailto:vinschen@redhat.com

--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com




--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list