Cygwin termcap entry for Solaris

Earnie Boyd
Fri Dec 1 09:26:00 GMT 2000

--- Steven Curtis <> wrote:
> Hello all,
> I regularly telnet net from a cygwin terminal to a Solaris box, and have
> never gotten vi to respond correctly regardless of what I set my TERM env var
> to.  I've tried vt100, vt220, ansi, and xter.  None seem to work properly. 
> Lately, I've tried grafting cygwin termcap entries from other Unix machines. 
> I've tried entries from an OpenBSD machine and a Linux machine, but captoinfo
> on Solaris never seems to be able to grok the entries.  It complains several
> times of "Termcap entry is too long" or "termcap code is not a valid name". 
> The resulting terminfo entries using tic on the output do a better job than
> adjusting the TERM env var, but they all have different problems.  I'm no
> termcap guru and couldn't write a valid entry to save my life.  Has anyone
> found or written a complete and correct termcap entry for a cygwin terminal
> type that works on Solaris?

1) leave the client side setting CYGWIN.
2) after managing to login change TERM to ansi.


Earnie Boyd

---         < >         ---
--- Cygwin: POSIX on Windows < > ---
---   Minimalist GNU for Windows < >   ---

Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.

Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list