cygwin programs won't end!

Richard Stanton stanton@Haas.Berkeley.EDU
Thu Apr 27 09:33:00 GMT 2000


And another followup... (This does sound rather similar to the current 40-80
second delay issue).

According to the administrators here there were some network problems
yesterday, but they're gone now.

However, I now have a different, related, and apparently worse, problem with
my cygwin programs. Yesterday, they ran, but then waited for ages before
giving me back my command prompt. Today, they don't run at all, but after a
minute or so start giving me error messages. For example:

[c:\]diff
    0       0 [main] (unknown) 0 lock_pinfo_for_update: rc 258, Win32 error
0
    0 10024362 [main] (unknown) 0 lock_pinfo_for_update: rc 258, Win32 error
6
10024615 20048977 [main] (unknown) 0 lock_pinfo_for_update: rc 258, Win32
error
6
10024207 30073184 [main] (unknown) 0 lock_pinfo_for_update: rc 258, Win32
error
6

These errors appear at intervals of c. 15 seconds, and I CAN now kill the
program using C-c, but I can't actually run any cygwin programs...

Richard Stanton
Associate Professor of Finance
Haas School of Business
U.C. Berkeley
545 Student Services Building #1900
Berkeley, CA 94720-1900

tel. (510) 642-7382
fax. (510) 643-1420
email: stanton@haas.berkeley.edu
Web: http://haas.berkeley.edu/~stanton



> -----Original Message-----
> From: Richard Stanton [ mailto:stanton@haas.berkeley.edu ]
> Sent: Wednesday, April 26, 2000 5:02 PM
> To: cygwin@sourceware.cygnus.com
> Subject: cygwin programs won't end!
>
>
> Below is a message I was about to send about cygwin programs not
> giving me back a command prompt. I subsequently found that the
> programs DO end eventually, but it takes several minutes (2-3) to
> get my command prompt back. This seems a little excessive....
>
> I remember some talk about network drives in the PATH possibly
> causing trouble like this, but my path only contains directories
> on my local drive C:. I AM on a network, though, and it strikes
> me I have had problems like this before when there have been
> network problems. Do cygwin programs for some reason do something
> network related after they've finished, but before returning to
> the command prompt (the delay is AFTER the output of the command
> seems to be complete).
>
> Richard Stanton
>
> ----------------
>
> Something strange has just happened on my machine (NT4/SP3, cygwin 20.1).
>
> Any cygwin program I run won't give me back my command prompt. As
> an example, at a DOS (4NT, but I've tried other shells and it
> makes no difference), I run "diff":
>
> [c:\scratch]diff
> diff: missing operand
> diff: Try `diff --help' for more information.
>
> The window is now frozen and needs to be killed. C-c and BREAK do
> nothing, either.
>
> I first noticed this using make inside Emacs to compile C code,
> but it seems to have affected all cygwin programs now.
>
> Any idea what's going on? I assume rebooting will help, but since
> I have a program running that has been going for 2 weeks now, and
> I don't feel like restarting it, I'd rather avoid that if
> possible, though right now I can't compile anything, which rather
> limits the usefulness of my machine...
>
> Richard Stanton
>



--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list