Possible race condition with sigsuspend in new net release

TOMMY REYNOLDS tommy.reynolds@adtran.com
Thu Apr 27 05:45:00 GMT 2000


Chris,

Using the 2000-04-26 snapshot, neither ZSH 3.1.6 nor the sigsuspend() test
from "configure" stalled on Win95.  I rebuilt ZSH, pointed my SHELL to that
file and then un-tar'ed, compiled and installed a small program, the "tsort"
program from UN*X.  That program also seemed to run fine.  I then ran
tar(1), gzip(1) and mv(1) a couple of times, still using the new ZSH image
as my shell, and nothing seemed amiss.

After the above activity and the new ZSH image sat for 30-45 seconds at the
shell prompt, I got an unsolicited line of output:

"D:\CYGWIN\TMP\ZSH-3.1.6\SRC\ZSH.exe: *** sync_with_parent - WFSO timed out"

so it looks as if you're on the right track with the basic fix, but there
may be another side effect here.  I have not been able to get this "WFSO
timed out" message again; if so, I'll let you know.

Thanks for the quick action.

> On Tue, Apr 25, 2000 at 08:16:14AM -0500, TOMMY REYNOLDS wrote:
> >> I don't have any problems running zsh but there were some signal fixes
> >> that went
> >> in after 1.1.0 was released.  Could you try a recent Cygwin snapshot
> and
> >> let
> >> cygwin@sourceware.cygnus.com know if it works any better?
> >> 
> >I reran the test using the 2000-04-25 snapshot and got the same results:
> the
> >stand-alone program hung but correctly ran to completion under the
> "strace"
> >tool.
> 
> Ok.  I managed to duplicate this sporadically on my Win95 laptop.  It
> looks
> like an incompatibility between Win95 and WinNT.
> 
> I've worked around this in the code.  I've just restarted a snapshot.  If
> you
> want to try it, download today's snapshot from
> 
> http://sourceware.cygnus.com/cygwin/snapshots/

--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list