Problem using Cygwin tools with perl's CPAN module

Paul Vasile
Mon Nov 22 20:07:00 GMT 1999

Hi there,
On a Win98 box, after installing the full.exe binary, making a /tmp, and
directory, as well as putting bash.exe and sh.exe in /bin ...

I went into the cygnus.bat shell, and ran the command:

    $ perl -MCPAN -e shell

I then configured my perl CPAN module to use various Cygwin tools (tar,
sh, etc.).
I gave the paths to the utils in:


When I then tried to run this command, from CPAN within the Cygwin shell:

    cpan> install Net::FTP

It downloads the module, uncompresses it, and gives me the following error:

    Uncompressed C:\perl\.cpan\sources\authors\id\GBARR\libnet-1.0607.tar.gz
    /cygnus/cygwin-b20/H-i586-cygwin32/bin/tar.exe: Cannot execute remote
shell: No such file or directory
    /cygnus/cygwin-b20/H-i586-cygwin32/bin/tar.exe: Cannot open
C:\perl\.cpan\sources\authors\id\GBARR\libnet-1.0607.tar: I/O error
    /cygnus/cygwin-b20/H-i586-cygwin32/bin/tar.exe: Error is not
recoverable: exiting now
    Couldn't untar C:\perl\.cpan\sources\authors\id\GBARR\libnet-1.0607.tar

I had to type that all out! ;( [harr harr]

I know that there is no problem with the tar file itself. This same error
message comes up for any module I try to install.

Perhaps this problem has to do with the CPAN module interpreting paths wrong
Windows... UNIX style paths (forward slashes), versus Windows (backslashes
a drive name).

Any workarounds, without having to modify the CPAN module itself? (that'd
for painful updates)


Paul Vasile
Gulf Island Digital
phone: (250) 247-9484
fax: (603) 907-5829

Want to unsubscribe from this list?
Send a message to

More information about the Cygwin mailing list