error: no acceptable ld found in $PATH

Mumit Khan khan@NanoTech.Wisc.EDU
Fri Dec 31 13:28:00 GMT 1999


Martin Weber <martweb@gmx.net> writes:
> --------------5A595952742BE6B574027AFA
> Content-Type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> 
> Now the problem with starting scripts without sh is solved. But there is
> an other problem. I tried do start ./configure form ImageMagick 5.1.
> Here is the result eventhough I can manually call ld without a problem.
> checking for ld used by GCC... no
> configure: error: no acceptable ld found in $PATH

Most of these questions have been dealt with in this list already, so
a search should produce the answer. Please do use the mailing list
archives.

This bug has been fixed in newer gcc releases, and you should definitely
upgrade to gcc-2.95.2 instead of using the original b20.1 compiler. See
http://www.xraylith.wisc.edu/~khan/software/gnu-win32/

  $ LD=/Cygwin/cygwin-b20/H-i586-cygwin32/bin/ld.exe ./configure ...

If you don't have /bin/sh.exe, then see my previous post:

  $ LD=/Cygwin/cygwin-b20/H-i586-cygwin32/bin/ld.exe CONFIG_SHELL=bash \
    bash ./configure ....

Regards,
Mumit


--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list