(Another) newbie problem

Simon Gornall simon@unique-id.com
Tue Aug 31 09:59:00 GMT 1999


I've been strugling with cygwin for a while, not quite sure of
what I've been doing wrong. Anyway, I decided to download a
fresh B20.1 full.exe and install the tools from Mumit's site
to get myself a working gcc-2.95

I installed the mingw32 extras into /lib and /include and prefixed
the g++ arguments with -I/include or -L/lib as instructed

Having done that, I tried compiling a simple hello-world.cc
file and it worked fine.

Next I tried the real source code, and I'm getting the following
(full -v output, sorry about that :-)

c -v -g -mno-cygwin -g -I/include -I../gtk+/gdk/win32 -I../glib
-I../gtk+ -I../jpeg-6b    -DDEBUG -c main.cc -o main.o
Reading specs from
//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/specs
gcc version 2.95 19990728 (release)

(so it's picking up the correct specs, I suppose. There is a directory
 ...i586-cygwin32/egcs-2.91.57/... as well, which I assume came from
full.exe)

 //E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/cpp.exe
-lang-c++ -v -I/include -I../gtk+/gdk/win32 -I../glib -I../gtk+
-I../jpeg-6b -iprefix
//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/
-D__GNUC__=2 -D__GNUG__=2 -D__GNUC_MINOR__=95 -D__cplusplus -Di386
-D_WIN32 -DWINNT -D_X86_=1 -D__STDC__=1
-D__stdcall=__attribute__((__stdcall__))
-D__cdecl=__attribute__((__cdecl__)) -D__declspec(x)=__attribute__((x))
-D__i386__ -D_WIN32 -D__WINNT__ -D_X86_=1 -D__STDC__=1
-D__stdcall=__attribute__((__stdcall__))
-D__cdecl=__attribute__((__cdecl__)) -D__declspec(x)=__attribute__((x))
-D__i386 -D__WINNT -Asystem(winnt) -Acpu(i386) -Amachine(i386)
-D__EXCEPTIONS -g -g -remap -Acpu(i386) -Amachine(i386) -Di386 -D__i386
-D__i386__ -Di586 -Dpentium -D__i586 -D__i586__ -D__pentium
-D__pentium__ -iwithprefixbefore
../../../../i586-cygwin32/include/mingw32 -D__MINGW32__=0.2 -DDEBUG
main.cc C:\WINDOWS\TEMP/ccRvaaaa.ii
GNU CPP version 2.95 19990728 (release) (80386, BSD syntax)
#include "..." search starts here:
#include <...> search starts here:
 /include
 ../gtk+/gdk/win32
 ../glib
 ../gtk+
 ../jpeg-6b

//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../i586-cygwin32/include/mingw32

//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../../include/g++-3

//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../../include

//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../i586-cygwin32/include
 //E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/include
End of search list.
The following default directories have been omitted from the search
path:
 /usr/include
End of omitted list.

//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/cc1plus.exe
C:\WINDOWS\TEMP/ccRvaaaa.ii -quiet -dumpbase main.cc -mno-cygwin -g -g
-version -o C:\WINDOWS\TEMP/ccyRaaaa.s
GNU C++ version 2.95 19990728 (release) (i586-cygwin32) compiled by GNU
C version 2.95 19990728 (release).
In file included from
//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../i586-cygwin32/include/asm/socket.h:4,
                 from
//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../i586-cygwin32/include/cygwin/socket.h:13,
                 from
//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../i586-cygwin32/include/sys/socket.h:5,
                 from Fetcher.h:28,
                 from main.cc:9:
//E/GNU/CYGWIN~1/H-I586~1/BIN/../lib/gcc-lib/i586-cygwin32/2.95/../../../../i586-cygwin32/include/cygwin/if.h:63:
syntax error before `;'
make: *** [main.o] Error 1

The line in question uses caddr_t, which is supposed to be set by
<sys/types.h> which 
I had already included, but I inserted it again before any other
include, unfortunately
this made no difference :-(

Presumably I've installed things in the wrong place somewhere. The
problem is that
there are so many places where include files go, that I'm not sure where
to start
looking... Any help about what I've done wrong appreciated.

ATB,	
Simon.

--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list