perl problems

Charles S. Wilson cwilson@ece.gatech.edu
Tue Aug 17 10:24:00 GMT 1999


Markus -
    Although I've never tried to use those particular modules, I see no
reason why they wouldn't work. However:

If you want to use modules, then you need to build perl from source
yourself. The reason for this is that the information used to compile
modules is built into the perl executable and scripts when perl.exe is
built. Thus, when you try to compile modules on *your* system, using the
perl binary I built on *my* system, the paths and stuff aren't correct.
Also, as you noticed, the permissions on the /usr/lib/perl5 tree, which are
OK on *my* system, don't work properly on *your* system (because your
username isn't "cwilson" and the /usr/local/lib/perl5 tree after untarring
is still owned by cwilson, most likely).

Eventually I hope to provide "drop-in" pre-compiled modules, that can be
untarred on top of an existing perl (as long as that perl was "my" binary
distro -- again, the whole path/script problem). Unfortunately, I haven't
been able to do that, yet -- and it'll probably be delayed until after the
perl5.6 release -- which hopefully will support cygwin out-of-the-box.

--Chuck


Markus Hoenicka wrote:

> I'm no perl geek, but I need to run a few perl scripts on my machine. I
> first tried Activestate's perl binaries. They work well and the scripts
> I need also install and run well - but this perl won't run in a bash,
> due to Win/Unix path incompatibilities, as I guess.
>
> Next tried the cygwin perl ports at http://cygutils.netpedia.net/ . I
> tried both the statically linked and the dynamically linked versions
> (binary version 1.4). which perl shows that I pick up the correct binary
> (not the Activestate stuff).
>
> When I try to install the modules I need (XML-Parser-2.26, XML-DOM-1.24,
> DelimMatch-1.04, dtdparse-2.0a2) with tar -xzf..., perl Makefile.PL,
> make, make install, perl tells me that I do not have the permission to
> install to perl5/5.00503/cygwin32, although the modules end up
> right there. When creating
> the makefile for XML-DOM it complains that XML-Parser-2.23 is not
> installed. XML-DOM still makes and installs fine except for the same
> permission complaint.
>
> Finally, one of the dtdparse scripts runs fine, the other stops with the
> following complaint:
>
> Can't load '/usr/local/lib/perl5/5.00503/cygwin32/auto/IO/IO.dll' for
> module IO:
>  126 at /usr/local/lib/perl5/5.00503/cygwin32/DynaLoader.pm line 169.
>
>  at /usr/local/lib/perl5/5.00503/cygwin32/IO/Handle.pm line 248
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/cygwin32/XML
> /Parser/Expat.pm line 11.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/cygwin32/XML
> /Parser.pm line 27.
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/XML/DOM.pm l
> ine 88.
> BEGIN failed--compilation aborted at
> /user/mhoen/software/dtdparse-2.0a2/dtdform
> at.pl line 24.
>
> (This is the output with the dynamically linked version. The statically
> linked version gives up much sooner, complaining it can't load
> XML-Parser)
>
> Is there any way to get perl up and running with CygWin?
> Thanks
> Markus
>
> --
> Markus Hoenicka
> UT Houston Medical School
> Dept. of Integrative Biology and Pharmacology
> 6431 Fannin MSB4.114
> Houston, TX 77030
> (713) 500-6313, -7476, -7477
> (713) 500-7444 (fax)
> mhoen@farmr1.med.uth.tmc.edu
> http://ourworld.compuserve.com/homepages/hoenicka_markus/
>
> --
> Want to unsubscribe from this list?
> Send a message to cygwin-unsubscribe@sourceware.cygnus.com


--
Want to unsubscribe from this list?
Send a message to cygwin-unsubscribe@sourceware.cygnus.com



More information about the Cygwin mailing list