standard headers not being found (NBY)

Earnie Boyd
Wed Jan 28 05:43:00 GMT 1998

Don't know if this will help; but, try removing the COMPILER_PATH 
variable.  I don't have it set and I am able to compile.  I believe the 
problem with it is that you don't have the correct path designation for 
this variable.  The compiler executables actually reside somewhere below 

Everything else looks nice, you even have binary mounts.

-        \\||//

Check out these great gnu-win32 related sites:           (ftp site)                   (Comercial Page)                (Project Page)                   (Mail Archives)    (HTML Man Pages)                               (Sergey Okhapkin)                (Sergey's ftp site)        (Colin Peters) (Mumit Khan)                   (Chuck Bogorad's ports) (Den Internet Services - US mirror and ports)  (GNU-Win32 Bash Configuration)

>Date: Tue, 27 Jan 1998 11:47:16 -0800
>From: Christopher Hahn <>
>Subject: standard headers not being found
>Hello Again,
>I have installed the binary versions of the gnu-win32 sdk and
>am trying to execute a test compile (Hello_World) and I keep
>getting the message that:
>	fooby.c:1: stdio: No such file or directory
>	gcc: Internal compiler error: program cpp got fatal signal 33
>I have tried many different system modifications, including setting
>variables, both with forward and backward slashes, in my autoexec.bat
>and in the NT environment settings dialog.  I have tried using
>the -I option on the gcc command line.  I have tried mounting various
>directories under various names.
>My Autoexec.bat sets:
>set GCC_EXEC_PREFIX=D:\gnuwin32\b18\H-i386-cygwin32\lib\gcc-lib\
>set    TCL_LIBRARY=D:/gnuwin32/b18/tcl/lib/tcl7.6
>set  GDBTK_LIBRARY=D:/gnuwin32/b18/share/gdbtcl
>set  COMPILER_PATH=D:/gnuwin32/b18/H-i386-cygwin32/bin
>set   LIBRARY_PATH=D:/gnuwin32/b18/H-i386-cygwin32/lib
>The command "mount" reports that:
>D:                              /            native   
>D:\gnuwin32\b18\H-i386-cygwin32 /usr         native   
>D:\<snip>\i386-cygwin32\include /usr/include native   
>So saying "ls /usr/lib" or "ls /usr/bin" looks good in bash.
>I am needing to find a discussion where someone has gone through the 
>process of setting up an NT's ENVIRONMENT so that the gnu native tools,
>installed binary versions, will operate properly.
>Thank you for the time,
>  Christopher Hahn --  <--Use this, it is not 
>#################HERE IS MY PREVIOUS POSTING###################
>Hello All,
>I have read through the FAQ, and it suggests that certain system
>variables can be set to allow for using the tools and I wanted to ask
>where possible values might be discussed.
>In most (or even all) cases I think that I can guess the most probable
>values, but I thought that somewhere there might be a discussion of the
>form "OK, if you installed the tools into //foo/bar/snook then you 
>would set GCC_EXEC_PREFIX to be....".
>This one example, GCC_EXEC_PREFIX, is a good one, as the FAQ suggests
>that "The C++ headers can now be found given a correctly set
>GCC_EXEC_PREFIX environment variable." But elsewhere the FAQ refers to
>the variable CPLUS_INCLUDE_PATH, which I would have thought would do
>the job ascribed to GCC_EXEC_PREFIX above.
>For help on using this list (especially unsubscribing), send a message 
>"" with one line of text: "help".

Get Your Private, Free Email at
For help on using this list (especially unsubscribing), send a message to
"" with one line of text: "help".

More information about the Cygwin mailing list