sockets and fork() under b18 coolview

Craig Nelson craig@reversion.ca
Thu Jan 22 16:37:00 GMT 1998


I am having trouble with a socket request server under win95.

If I write a program to handle incoming socket requests, one at a time, the
program runs beautiful.  however, if I modify the program to use fork() to 
process each socket request, the program dumps, reporting that the stack is
probably corrupted.

I've tried to narrow the problem down using a small test case program, and that
also runs fine with, or without fork().  But using the original program under
every other unix works flawlessly as well (even purified).

My theory is this:  

	-Because the original program runs fine with unix, i will assume its ok.

	-Because the original program runs fine when used on gnu-win32 without
	 fork(), i will continue to assume that it's ok.

	-The smaller test program only worked because it did not "do enough"
	 other processing for the system to realize that the stack had been
	 corrupted.

And so I conclude that the problem is with fork() under gnu-win32.

Has anyone else experienced this scenario with fork?

I've checked all the archives, FAQs and everything, so this is my last resort.

I would certainly appreciate any help anyone has to offer..

Thanks,
Craig Nelson, Cameo Systems.

craig@reversion.ca
-
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".



More information about the Cygwin mailing list