make and Watcom's wrc

mesc merten.schumann@informatik.tu-chemnitz.de
Fri Jan 9 00:17:00 GMT 1998


Hello,

I've got a problem in driving Watcom's resource compiler (wrc)
by gnuwin32 make. I have to call the rc with this command line
   wrc -bt=nt -r -DFOO="88.55" -FO=xxx.res xxx.rc
The wrc responds with 'syntax error near "88.66"'. When I use the
same command in a normal DOS box everything goes fine. The problem
seems to be, that the wrc doesn't get the quotes ("). I tried some
constructs, like "\"88.66\"", with no success. I even tried to
invoke a .bat file with the command from the makefile. It doesn't
work too! When I call the .bat file in a normal DOS box it works.

I could use a workaround and let sed edit the xxx.res on the
fly and then call the wrc without the -DFOO="88.55" but maybe
there is a better solution.

Could please anyone give me a hint how to solve this problem?
Thank you!
   Merten

-
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".



More information about the Cygwin mailing list