Problems using bash or tcsh under NT emacs

Daniel Karipides
Mon Dec 14 12:10:00 GMT 1998

I'm have some questions about using either cygwin B20.1 bash or the
cygwin port of tcsh under the new NT emacs (

My problems:

If I follow the instructions on the NT emacs FAQ for tcsh, the shell
actually runs except there are two major problems.

(1) The shell complains that there is no tty and thus, job control will
be disabled.  This had been mentioned before on the cygwin mailing list
but I'd just like to let other know that I'm having the same problem.

(2) ^M's are not stripped from the shell window.  I added the
suggested line to the .emacs file, but still no success.

So, is anyone currently using the new NT emacs successfully with tcsh?

If I follow the instructions on the NT emacs FAQ for bash, the shell
won't even run.  Rather, it starts and then dies with the error
"Invalid shell arguments".  I have tried setting variable such as:


to nil with no success.  I haven't tried:


but I hope you don't have to do that...

Any suggestion would be greatly appreciated.

If it helps, I am running:

NT4 SP4 on a Pentium Pro 200MHz
Cygnus B20.1
NT emacs


For help on using this list (especially unsubscribing), send a message to
"" with one line of text: "help".

More information about the Cygwin mailing list