#!/bin/sh troubles

Christopher Seawood cseawood@qualcomm.com
Mon Dec 7 15:51:00 GMT 1998

I just uninstalled b20 and installed b20.1 and autoconf stopped working.
(Actually, it never quite worked under b20, either.)  

I copied b20.1's sh.exe to /bin/sh and cp removed the execute permissions.
Chmod'ing the binary did not work either.  So I moved /bin/sh to 
/bin/sh.exe.  Autoconf runs and spits 6 lines of control chars, each
ending with ": not found".  Then it spits out
     /bin/sh.exe: 11: Syntax error: ")" unexpected.  

I removed it and copied bash.exe to /bin/sh.exe.  Then I got this error:
    /bin/sh.exe: /bin/sh.exe: cannot execute binary file

Using 'sh /usr/bin/autoconf' or 'bash /usr/bin/autoconf' works fine
though but I can't quite build a rpm that way.

"what I do know is I ran a Linux box for a week in the middle of year
 2014 with no problems" - Alan Cox on the year 2000 problem

For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".

More information about the Cygwin mailing list