b20.1: binmode and pipes

John A. Turner john.turner@pobox.com
Mon Dec 7 03:19:00 GMT 1998

OK, I must admit that I've tried to steer clear of the whole
text/binary thing since it wasn't presenting any problems for
me.  But it appears that something has changed between b19
and b20.1.

As part of my build process I run a gawk script and pipe the
output through sort and uniq to generate dependencies.  In b19
this worked fine.  In b20.1, the gawk part works fine, but as
soon as it goes through the pipe to sort, each line has an
extra ^M.  Needless to say this confuses things.

Possibly relevant settings:

CYGWIN="notitle tty"

I tried adding nobinmode to CYGWIN, but that didn't change

I have no binary mounts (in fact no mounts at all).

Is there something simple I can add to CYGWIN or something or
am I just going to have to bite the bullet and strip them at
the end of the pipe myself?


John A. Turner
Blue Sky | VIFX    - http://www.blueskystudios.com/
   "Bunny"         - http://bunny.blueskystudios.com/
    (a new fully computer-generated animated short film)
Los Alamos Nat Lab - http://www.lanl.gov/home/turner/
Personal           - http://john.turner.org/
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".

More information about the Cygwin mailing list