BUG: umount / && mount d:/ / doesn't work.

Larry Hall lhall@rfk.com
Sat Aug 29 12:11:00 GMT 1998

At 06:56 AM 8/28/98 -0700, Earnie Boyd wrote:
>I've just found that in order to change the root directory to
>something other than c:\ that I must use regedt32 and modify the key
>I found this bug when trying to explain the process to someone else. 
>I modified my mounted root directory with `umount / && mount d:/ /'
>and found that it did the umount and immediately pointed the / to c:
>so that when it executed the mount command mount complained about a
>`busy device'.  I tried this sequence also under MSDOS with nothing
>else running and got the same results.
>This used to work in b18, so if I were looking for the problem (which
>I won't be) I would look at the code that changed for the addition of
>the HKEY_LOCAL_MACHINE registry entry.
>-        \\||//

Works for me on NT.  Are you sure you tried this under cygwin bash?  It
will work exactly as you described if not.

Larry Hall                              lhall@rfk.com
RFK Partners, Inc.                      (781) 239-1053
8 Grove Street                          (781) 239-1655 - FAX
Wellesley, MA  02482-7797               http://www.rfk.com
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".

More information about the Cygwin mailing list