How to start inetd as NT service ?

Michael Czapski MCzapski@openplus.com.au
Thu Aug 13 14:53:00 GMT 1998


Hello,

For the past few days I have been trying to get the remote suite to work on Win 
NT4SP3, B19.3, i.e. B19 with B19.1 and latest Coolview.  Eventually I managed 
to get inetd to start as a service but with complaints from the Services 
Applet.  I used NT Resource Kit's SRVINSTW.EXE to install the service with name 
inetd.  It shows up in the Services applet.  I set it up to start as 
'LocalSystem' user, following Sergey's advice though I added the required 
rights to the Administrator account and tried that as well.  The service 
starts, as witnessed by the 'netstat -an' and the ability to telnet to the 
machine however the Services Applet, when one presses the 'start' button, 
'thinks' for a long time and eventually comes back with 'Could not start the 
inetd service on \\zcat', followed by 'Error 2186: The service is not 
responding to the control function'.  I tried with the '-d' in the parameters 
box and without, both using LocalSystem and Administrator.  Same results.  I 
scoured the archives for tips/hints/whatnots to no avail.  Sure enough, there 
are plenty of messages relating to the remote suite however most of the start 
with 'I have inetd starting as NT service ...' :-) which is a bit further than 
I can get.  As I say it is working, sort of, but bewfore I set it up to start 
'automatic' I would like to see it behave.  Also, where do I put the '-d' 
option ?  There appears to be no place to put it in the srvinstw.exe's dialog 
boxes.

Can someone or more please give me a hint or two ?

TIA

------------------
Cheers ...
Michael Czapski


-
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".



More information about the Cygwin mailing list