B19[.1]: MAJOR problems -- foreign filenames broken; script claims all files can't be found

Dan Harkless dan@cafws3.eng.uci.edu
Sat Apr 18 02:59:00 GMT 1998

I just tried upgrading from B18 to B19.1, but the new version is totally
unusable to me.  I have a bunch of test files from our Japanese customer
that have Japanese names.  With B18, the filenames just looked like a
bunch of junk characters.  With B19.1, cygwin32 claims that the files
"can't be found", whether I use ls, find, or whatever.  An example
filename (as it shows up with ls -b): 


Also, I have a script which backs up a bunch of files to my UNIX
account.  Under B19.1, every call to tar says "file not found" for every
file.  If I run the commands in the script from the commandline, they
work fine (and of course the script works under B18).  I will include
the script as a MIME attachment.

Unfortunately I didn't try any of this on B19 (just B19.1), and I've now
deleted all traces of B19.1 from my system (I was paranoid I wouldn't be
able to get B18 working again).

Dan Harkless           | NOTE: Due to SPAM I have implemented a caller-
Unitech Research, Inc. | ID-like policy for this account.  Put "re-send"
dan@cafws3.eng.uci.edu | in your Subject to bypass; finger me for more.

More information about the Cygwin mailing list