errno missing in link of wget

Theodore W. Leung twl@pobox.com
Tue Jun 10 21:22:00 GMT 1997


I've been puzzling over this one....

I'm running gnuwin32-b18 on NT 4.0 + SP2 + Hotfixes.

I tried to build GNU's wget-1.4.5 by downloading from gatekeeper,
decompressing and untaring, and running configure.  configure ran okay, so
I type'd make.

All the source files compile, but I get this for a link:

gcc  -o wget connect.o host.o http.o netrc.o ftp-basic.o ftp.o ftp-ls.o
mtch.o h
tml.o retr.o recur.o url.o init.o utils.o cmpt.o getopt.o main.o version.o
http.o(.text+0x835):http.c: undefined reference to `errno'
http.o(.text+0x8f5):http.c: undefined reference to `errno'
http.o(.text+0xfb4):http.c: undefined reference to `errno'
http.o(.text+0x154f):http.c: undefined reference to `errno'
http.o(.text+0x1df9):http.c: undefined reference to `errno'
http.o(.text+0x23ac):http.c: more undefined references to `errno' follow
gcc: Internal compiler error: program ld got fatal signal 1
make: *** [wget] Error 1
make: *** [src] Error 2

I can compile a simple program that calls socket and check's errno, so it's
some weird thing that configure did.  Any hints on how to debug this?  

Thanks,

Ted 
______________________________________________________________________________
Ted Leung	twl@pobox.com or twl@alum.mit.edu      http://pobox.com/~twl
______________________________________________________________________________

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: 2.6.2

mQBtAzKVWM8AAAEDAMcGqhQaOwR3lZGSRWXPGValB1dyZM+uWPlzwnIoaL5an8Do
wkvXEfMWCVkiuHQW4yh631RSHFvrftgVvJgKXB1+WYMDDP1V7nGeemT5EF3oUIU0
BxdTSRd3c841lLe5TQAFEbQhVGhlb2RvcmUgVy4gTGV1bmcgPHR3bEBwb2JveC5j
b20+
=U9O6
-----END PGP PUBLIC KEY BLOCK-----
-
For help on using this list (especially unsubscribing), send a message to
"gnu-win32-request@cygnus.com" with one line of text: "help".



More information about the Cygwin mailing list