xterm crashing when trying to access Ctrl-<mouse click> menu items

Jon TURNEY jon.turney@dronecode.org.uk
Mon May 12 10:34:00 GMT 2014

On 05/05/2014 19:39, Nem W Schlecht wrote:
> For over a month now I've been having issues with my xterms in Cygwin.
>   If I try to access *any* menu item under the Ctrl-<mouse button> menu
> items (change font, turn on/off scrollbar, redraw window, etc.), my
> xterm crashes the moment I un-press my mouse button.  I don't access
> them all that often, so I don't know how long the issue has been
> around, but it's been a couple of months now.
> I've tried launching it with an empty .Xdefaults file (home dir) and
> by moving my .bashrc/.bash_profile files out of the way - still the
> same result.  I've also gone out and downloaded the latest XTerm code
> and have a version compiled with debugging, but my C skills are really
> rusty and I'm not seeing anything terribly useful in gdb (I set my
> CYGWIN env var to "error_start=dumper -d %1 %2" so I would get core
> dumps).  I compiled a version with a different "DEFCLASS" set so that
> I *know* it's not a bad resource or resource file.
> I'm running 64 bit on Windows 7.  More details in the attached cygcheck.out.
> Anybody else on 64bit Cygwin / Win 7 having the same issues?

Thanks for reporting this issue.  I can reproduce it.

This appears to be an issue with Xt, as a Cygwin-specific patch does not 
work correctly on x86_64 when another DLL which is using Xt is loaded 
 >2GB away from it.

Until we have a fix, you *might* be able to work around this by rebasing 
the DLLs, e.g. in the specific case of xterm, which uses Xaw:

cd /usr/bin
rebase -v -b 0x400000000 cygXt-6.dll
rebase -v -b 0x410000000 cygXaw-7.dll

Volunteer Cygwin/X X Server maintainer

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list