xterm crashing when trying to access Ctrl-<mouse click> menu items

Nem W Schlecht nem@emptec.com
Mon May 5 18:39:00 GMT 2014

Hello all,

For over a month now I've been having issues with my xterms in Cygwin.
 If I try to access *any* menu item under the Ctrl-<mouse button> menu
items (change font, turn on/off scrollbar, redraw window, etc.), my
xterm crashes the moment I un-press my mouse button.  I don't access
them all that often, so I don't know how long the issue has been
around, but it's been a couple of months now.

I've tried launching it with an empty .Xdefaults file (home dir) and
by moving my .bashrc/.bash_profile files out of the way - still the
same result.  I've also gone out and downloaded the latest XTerm code
and have a version compiled with debugging, but my C skills are really
rusty and I'm not seeing anything terribly useful in gdb (I set my
CYGWIN env var to "error_start=dumper -d %1 %2" so I would get core
dumps).  I compiled a version with a different "DEFCLASS" set so that
I *know* it's not a bad resource or resource file.

I'm running 64 bit on Windows 7.  More details in the attached cygcheck.out.

Anybody else on 64bit Cygwin / Win 7 having the same issues?

Nem W Schlecht                   nem@emptec.com
Empyreal Technologies    http://www.emptec.com/
 "Perl did the magic.  I just waved the wand."
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 268615 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin-xfree/attachments/20140505/7b3ca9fd/attachment.obj>
-------------- next part --------------
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list