X server doesn't start with a empty .startxwinrc

Marco Atzeri marco.atzeri@gmail.com
Thu Dec 18 11:20:00 GMT 2014

On 12/18/2014 11:51 AM, Jean-Marc Colagrossi wrote:
> Hi all,
> I need you help to understand what's wrong with X server or my .startxwinrc
> file.
> I work with X server -> Xterm and vim since month now. Every thing was
> always working perfectly.
> Yesterday I upgraded all cygwin packages and just after that I was unable to
> start X server again.
> I made a new fresh installation and X server works correctly. Then I made a
> copy of my olds files like .startwinrc, .bashrc .vimrc and all my shortcuts.
> When I tried to start the X server I had the same problems. X server crashed.
> I removed one by one all the files I copied up to I deleted .startxwinrc.
> Then the X server start correctly. my .startxwinrc had only 3 lines with :
> xterm -bg Black -fg White&
> I deleted all the lines just to have a blank .startxwinrc. But X server
> still crashes.
> Here is the log when I run startxwin from terminal with an empty
> .startxwinrc file
> I don't understand what I did wrong as it was working fine before.

xinit behavior is changed, see relative announcement

It will execute all command of .startxwinrc  or startxwinrc
and then the X server will shutdown.

you can
1) remove .startxwinrc, so that the default will prevail.
    see for an example /etc/defaults/etc/X11/xinit/startxwinrc

2) you put in .startxwinrc any command without "&"
    and the xserver will close when that command will end.

    as examples:
      xterm -bg Black -fg White
      sleep inf

You are not the first one, that was caught by surprise.
Re-reading the announcement helped me on understanding the matter.

> Thank you
> Regards,
> Colagrossi Jean-Marc


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list