X server doesn't start with a empty .startxwinrc

Jean-Marc Colagrossi jean-marc@colagrossi.ch
Thu Dec 18 10:55:00 GMT 2014

Hi all, 

I need you help to understand what's wrong with X server or my .startxwinrc

I work with X server -> Xterm and vim since month now. Every thing was
always working perfectly.

Yesterday I upgraded all cygwin packages and just after that I was unable to
start X server again.

I made a new fresh installation and X server works correctly. Then I made a
copy of my olds files like .startwinrc, .bashrc .vimrc and all my shortcuts.
When I tried to start the X server I had the same problems. X server crashed.

I removed one by one all the files I copied up to I deleted .startxwinrc.
Then the X server start correctly. my .startxwinrc had only 3 lines with :

xterm -bg Black -fg White&

I deleted all the lines just to have a blank .startxwinrc. But X server
still crashes.

Here is the log when I run startxwin from terminal with an empty
.startxwinrc file

I don't understand what I did wrong as it was working fine before.

Thank you


Colagrossi Jean-Marc

$ startxwin

Welcome to the XWin X Server
Vendor: The Cygwin/X Project
OS: CYGWIN_NT-6.1 LSALT054 1.7.33-2(0.280/5/3) 2014-11-13 15:47 x86_64
OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (Win64)
Package: version 1.16.2-1 built 2014-11-11

XWin was started with the following command line:

/usr/bin/XWin :0 -multiwindow -nolisten tcp -auth

(II) xorg.conf is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
LoadPreferences: /home/jmcolagrossi/.XWinrc not found
LoadPreferences: Loading /etc/X11/system.XWinrc
LoadPreferences: Done parsing the configuration file...
winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
winDetectSupportedEngines - Returning, supported engines 00000015
winSetEngine - Multi Window or Rootless => ShadowGDI
winScreenInit - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 2680 height: 1920 depth: 32
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of
shared memory support in the kernel
glWinSelectGLimplementation: Loaded 'cygnativeGLthunk.dll'
GL_VERSION:     4.2.12434 Compatibility Profile Context
GL_VENDOR:      ATI Technologies Inc.
GL_RENDERER:    AMD Radeon HD 8750M
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: enabled GLX_SGIX_pbuffer
(II) AIGLX: enabled GLX_ARB_multisample and GLX_SGIS_multisample
(II) 109 pixel formats reported by wglGetPixelFormatAttribivARB
(II) AIGLX: Set GLX version to 1.4
(II) 32 fbConfigs
(II) ignored pixel formats: 0 not OpenGL, 12 RBGA float, 30 RGBA unsigned
float, 0 unknown pixel type, 35 unaccelerated
(II) GLX: Initialized Win32 native WGL GL provider for screen 0
winPointerWarpCursor - Discarding first warp: 1340 960
(--) 16 mouse buttons found
(--) Setting autorepeat to delay=500, rate=31
(--) Windows keyboard layout: "0000100C" (0000100c) "Swiss French", type 4
(--) Found matching XKB configuration "French (Switzerland)"
(--) Model = "pc105" Layout = "ch" Variant = "fr" Options = "none"
Rules = "base" Model = "pc105" Layout = "ch" Variant = "fr" Options = "none"
The XKEYBOARD keymap compiler (xkbcomp) reports:
 Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
winInitMultiWindowWM - DISPLAY=:0.0
winMultiWindowXMsgProc - DISPLAY=:0.0
winProcEstablishConnection - winInitClipboard returned.
winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the
winClipboardThreadProc - DISPLAY=:0.0
OS maintains clipboard viewer chain: yes
winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened
the display.
winClipboardProc - XOpenDisplay () returned and successfully opened the display.
xinit: XFree86_VT property unexpectedly has 0 items instead of 1
xinit: connection to X server lost

waiting for X server to shut down winClipboardProc -
winClipboardFlushWindowsMessageQueue trapped WM_QUIT message, exiting main loop.
winClipboardProc - XDestroyWindow succeeded.
winInitMultiWindowXMsgProc - Caught IO Error.  Exiting.
winDeinitMultiWindowWM - Noting shutdown in progress
(EE) Server terminated successfully (0). Closing log file.

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list