startxwin.exe no longer exists?

Will Parsons varro@nodomain.invalid
Tue Dec 16 02:50:00 GMT 2014

Marco Atzeri wrote:
> On 12/12/2014 7:07 PM, Will Parsons wrote:
>> For several years now I have been starting X windows by clicking on an
>> icon on my desktop that is a link to C:\cygwin\bin\startxwin.exe.  It
>> has recently ceased to work because apparently startxwin.exe no longer
>> exists.  Somehow I missed where this was removed, so what is the
>> recommended way of starting X from a desktop icon now?
>> I seem to recall that startxwin.exe was introduced some time ago
>> because using a script to start X was inadequate somehow, but I don't
>> remember the details, so what changed?

OK - so what I get from that is that whatever problems were associated
with the original shell script have been solved and startxwin is now a
shell script again.  But, my basic question is unanswered - how do I
start an X session from an icon?  Obviously, simply replacing the link
to startxwin.exe to startxwin will not work, so I copied the shortcut
from the start menu to the desktop and tried it (after renaming my
.xinitrc and .startxwinrc files to avoid any problems with the change
of model).

If I click on the icon, I *do* get an X session (along with an xterm
that I don't need), but if try (e.g.) to start emacs under mintty, I
get a non-X emacs, with an error message:

  Display :0 unavailable, simulating -nw

Sure, display :0 is unavailable; checking DISPLAY in the (unwanted)
xterm shows DISPLAY is set to :5.  Why's that I wonder?

Further investigation shows ls -ltr /tmp:

-r--r--r--  1 william None 11 Nov 28 17:43 /tmp/.X0-lock
-r--r--r--  1 william None 11 Dec 13 17:43 /tmp/.X1-lock
-r--r--r--  1 william None 11 Dec 13 17:55 /tmp/.X2-lock
-r--r--r--  1 william None 11 Dec 13 19:22 /tmp/.X3-lock
-r--r--r--  1 william None 11 Dec 15 16:53 /tmp/.X4-lock
-r--r--r--  1 william None 11 Dec 15 17:00 /tmp/.X5-lock

Interesting.  It looks like every time I start an X session a lock
file is created and doesn't get deleted, so the display number keeps
changing.  This doesn't look right, so how do I avoid it?


Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list