remote xterm's can't open display after upgrade

Fri Dec 12 19:55:00 GMT 2014

Don Webster <paxguy <at>> writes:

> After the upgrade, I can't display remote xterms. OK, my old X shortcut 
didn't work, but I found "XWin
> Server" and pinned it to my task bar. I launch that and I have the X 
server running, and a local xterm pops up. I
> ssh into my linux server, and run my xterm, and get "can't open display". 


> This was all working on Monday with my older version of cygwin-x, which I 
think was a 2011 vintage. (I don't
> upgrade stuff very often for this very reason.) 
> Attached is my log. 
> Any help is appreciated. In general, I love cygwin and cygwin-x; it is 

Hi Don,
   I'm in the same boat.  I just upgraded cygwin and now I can't get remote xterms to 
display on the local machine.

   The previous version of startxwin.exe started a  server on
 DISPLAY=IPAddress:0.0 and I could display remote Xte rms because
 I'd set the remote DISPLAY variable to the same value, and they 
could get to the PAddress.   The new version of startxwin.exe uses 
DISPLAY=:0.0, and remote xterms won't display/can't find my machine.
  I tried setting the remote machine's DISPLAY=IPAddress:0 and to 
DISPLAY=machinename:0, but I get "Error: Can't open display: IPAddress:0" 
or "Error: Can't open display: machinename:0"
   On the local machine I tried "xhost + remotemachine" and "xhost +", still 
no luck.

   Still looking for an answer...


Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list