Strange interaction between Cygwin/X and Mozilla Firefox Bookmarks

Tue Sep 24 18:49:00 GMT 2013

On 23/07/2013 22:15, Falk Tannhäuser wrote:
> Am 23.07.2013 14:59, schrieb Jon TURNEY:
>> I can't reproduce this.
>> I think there must be some other factor at work: the XWin error message
>> relates to a timeout during X -> Windows clipboard conversion, but I can't
>> make clicking on a firefox bookmark cause that conversion to happen.
>> There are definitely bugs in this area, so any additional information you can
>> provide would be helpful.
> After deeper investigation, it occurs that the problem is triggered by gnuplot
> in particular (I was effectively unable to reproduce it with a few other X11
> applications, as xterm, xfig, xdvi or ddd). Most of the time I use gnuplot
> from within Octave, but the easiest way to reproduce the problem is by
> launching gnuplot directly in a Cygwin terminal window, then entering "plot
> sin(x), cos(x)" on the gnuplot prompt to open an X11 pop-up window containing
> a plot. Here is the terminal output from gnuplot:
> $ gnuplot
>          G N U P L O T
>          Version 4.6 patchlevel 3    last modified 2013-04-12
>          Build System: CYGWIN_NT-5.1 i686
>          Copyright (C) 1986-1993, 1998, 2004, 2007-2013
>          Thomas Williams, Colin Kelley and many others
>          gnuplot home:
>          faq, bugs, etc:   type "help FAQ"
>          immediate help:   type "help"  (plot window: hit 'h')
> Terminal type set to 'x11'
> gnuplot> plot sin(x), cos(x)
> gnuplot>
> After this, clicking on Firefox bookmarks shows the problem - also when using
> the bookmark window opened with Ctrl-Shift-B. I also tried to relaunch FF in
> "safe mode" i.e. with add-ons disabled, with the same result. After closing
> gnuplot it is necessary to wait for a few minutes until FF's behaviour returns
> to normal; alternatively one can close the X server to restore the normal
> function of FF immediately.

Thanks for taking the time to investigate this, and the detailed reproduction

This is indeed a strange interaction.  The problem seems to be (i) (for some
reason) Firefox asks for the current clipboard contents when any of the
bookmarks are clicked on, (ii) gnuplot puts an image of the current plot in
the PRIMARY selection, and (iii) a previous fix to clipboard integration code
[1] has the unforeseen negative side-effect that when the monitored selection
cannot be converted to text, the clipboard integration code sits there waiting
for up to a second, which blocks the Windows application which asked for the
clipboard contents (Firefox in this case)

Thanks for reporting this problem.

I've added a patch which tries to fix this behaviour by actually checking if
the selection can be converted to a text format before trying, and uploaded a
snapshot at [2]. Perhaps you could try that and see if it improves things for you?


Volunteer Cygwin/X X Server maintainer

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list