X server crash when running texworks

Ken Brown kbrown@cornell.edu
Mon Mar 26 19:47:00 GMT 2012

On 3/24/2012 3:47 PM, Ken Brown wrote:
> To reproduce:
> 1. Install texworks-0.4.3-1 from Cygwin Ports.
> 2. Create two tex files in your home directory, say test1.tex and
> test2.tex. I don't know if the contents matter, but in my case both
> files contain the following:
> \documentclass{article}
> \begin{document}
> Hello
> \end{document}
> 3. Start the X server by using the Start Menu shortcut.
> 4. Start texworks by typing "texworks&" in an xterm window.
> 5. Click on the "Open" icon to open one of the tex files. Then do the
> same to open the second.
> At this point the X server crashes and gives the message "Caught signal
> 11 (segmentation fault)". Server aborting."
> Before the crash I get the following warning in the xterm window when I
> open a file:
> QFileSystemWatcher: failed to add paths: /home/kbrown
> I don't know if this is significant.su
> I'm attaching cygcheck output and XWin.0.log.
> Ken
> P.S. I'm currently using the test version of xorg-server (1.12.0-1), but
> I can reproduce the crash with 1.11.4-5 also. Also, I'm currently
> testing the latest Cygwin snapshot. I just tried reverting to 1.7.11,
> and the X server still crashed, but not just from opening two files. I
> had to open and compile several tex documents before it happened.

One further detail for anyone trying to reproduce this:  I just tried it 
on a second computer, and my recipe didn't immediately produce the 
crash.  But I simply started trying to use texworks (loading and 
compiling various tex documents), and the X server crashed within a few 


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list