Xwin.exe always take about 50% CPU load on Windows 7 with XDCMP connection

Kees Dekker Kees.Dekker@infor.com
Mon Mar 5 07:39:00 GMT 2012


Thanks for your reply. I looked in the mail archives about what was solved, and thus missed indeed this announcement. So I apparently looked at the wrong place, or the wrong month of the archive, sorry.
My keyword where I searched for was 'CPU' 'load'.


On 02/03/2012 09:24, Kees Dekker wrote:
> I’m using Xwin.exe (version 5. Feb 2012, X.org servers – 1.11.4-3) on my
> Windows 7 system. When connecting with XDCMP (using startxdcmp.bat, with
> %RUN% XWin -query %REMOTE_HOST% -once -lesspointer -clipboard
> -emulate3buttons), after connect, the CPU load is about 50%. Even when
> nothing is done (only the CDE desktop is running, nothing else).
> On another Windows 7 system, also connecting with XDCMP to the same server,
> same CDE, the CPU load is not that high. The version of XWin is one of 5.
> Feb 2009.
> The XCDMP server is a Solaris 10 system, using Solaris classic CDE (not the
> Java Desktop environment). The high CPU load did not happen when the CDE
> waits for the logon screen, but happens as soon as login was completed.
> BTW. Just when I was writing this email I decided to check (again) for a
> newer version, and there was one… Moving to X.org servers 1.11.4-5 seems to
> solve this issue ☺. However, I did not find any release note telling that
> this problem was solved….

I'm not sure where you were looking if you didn't find [1].

'On Cygwin 1.7.10 this caused XWin to spin, when started from a non-cygwin
process, spamming the log with  "_XSERVTransSocketUNIXAccept: accept() failed"

[1] http://cygwin.com/ml/cygwin-xfree-announce/2012-02/msg00004.html

Volunteer Cygwin/X X Server maintainer

More information about the Cygwin-xfree mailing list