Sat Mar 5 18:05:00 GMT 2011

On 04/02/2011 17:14, Ken Olum wrote:
>    From: Jon TURNEY <>
>    Date: Mon, 24 Jan 2011 18:38:36 +0000
>    > Once I say -wgl, direct rendering no longer works.  That is, if I
>    > don't set LIBGL_ALWAYS_INDIRECT, then I get a long (infinite?)
>    > sequence of errors like this:
>    > 
>    > X Error: BadMatch (invalid parameter attributes) 8
>    >   Major opcode: 73 (X_GetImage)
>    >   Resource id:  0xa0039a
>    I can't reproduce this problem.  Can you give me a few more details on the
>    host which is running paraview: unix version, version of libGL and version of
>    paraview?
> Mandriva 2010.2 on x86_64 with kernel
> libGL is from lib64mesagl1-devel-7.8.1-6mdv2010.1
> Paraview is version 3.8.1 for x86

Thanks for the info.

I tried to reproduce this problem using the x86 version of the above (I don't
have any hardware capable of running x64 VMs at the moment), with no success,
so either it's specific to x64 in some way, or there's something else I need
to do.

> I don't have a clear picture of when this bug occurs and when it doesn't.
> I just deleted my paraview configuration file .config/ParaView/ParaView3.8.1.ini
> to start with a clean environment, and now when I type paraview it
> gives me a large but finite number of these warnings and then starts
> up.
> When I create objects (e.g., try Sources->Arrow) it displays them
> without further errors, but extremely slowly.  You can watch the
> individual polygons appear on the screen.
>    Do you get that error with other OpenGL applications (e.g. glxinfo) or just
>    paraview?
> glxinfo does not give these errors.  I haven't tried any other OpenGL
> application.

Volunteer Cygwin/X X Server maintainer

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list