Problems running graphic interface in a remote host

Tue Jul 26 13:21:00 GMT 2011


I found the issue, xhost wasn't automatically installed so I had to do it
manually and run it form my host. Now it works.

I've tried also connecting with ssh forwarding before, but when I issue ssh
-Y my keyboard is not working properly anymore, I think I need to use the
setxkbmap option, but I'm fine connecting without the ssh forwarding.

Thanks for your help.

Jon TURNEY wrote:
> On 20/07/2011 12:18, Ciro wrote:
>  > I'm running Cygwin/X, yes, I can run xterm or rxvt locally, in fact I
> could
>  > run the graphic interface in the remote server until I installed the
> new
>  > Cygwin/X. I'm not sur ewhat the problem could be.
> On 21/07/2011 15:06, Ciro wrote:
>> I've installed the new Gygwin set in my computer and I can't seem to
>> start
>> any graphic interface in a remote host, for instance:
>> (C)SUMFO$ xclock&
>> [1]     973
>> (C)SUMFO$ Xlib: connection to "" refused by server
>> Xlib: No protocol specified
>> Error: Can't open display:
>> [1] +  Done(1)                 xclock&
>> The DISPLAY variable is fine, I've enabled X11 forwarding (I've tried
>> also
>> without enabling this option):
>> ForwardX11 yes
>> but it's still failing, I've googled for this issue with cygwin but
>> couldn't
>> find anything, any help would be appreciated
> I still can't tell if you are using ssh forwarding or not.
> If you are using ssh forwarding, that DISPLAY setting is wrong, you should 
> leave it at what sshd sets it to on the remote host (typically something
> like 
> localhost:10.0)
> If you aren't using ssh forwarding (not recommended), you need to use
> xhost 
> on the cygwin computer to allow access by the remote host (or equivalent
> actions)
> I'm not sure why this would have stopped working after upgrading X
> (although 
> you don't say what version from). Perhaps you had added the X server -ac 
> option in the script used to start the X server, which had been updated?
> [1]
> [2]
> -- 
> Volunteer Cygwin/X X Server maintainer
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

View this message in context:
Sent from the cygwin-xfree mailing list archive at

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list