Wed Jan 19 21:11:00 GMT 2011

On 19/01/2011 18:53, Ken Olum wrote:
>    From: Jon TURNEY <>
>    Date: Sun, 02 Jan 2011 18:08:02 +0000
>    I would suggest that for an application like ParaView, you will probably get
>    much better performance if you use the experimental hardware accelerated
>    OpenGL -wgl mode, see [2] for details.
>    [2]
> I tried this, but it did not work.  First I tried it in single-window
> mode, and that gave an error in XWin.0.log that it wouldn't work with a
> root window.  

Yes, sorry for not making that limitation clear.

> So then I said XWin -wgl -multiwindow, and in my
> XWin.0.log I have the following error:
> [  8581.437] (II) AIGLX: enabled GLX_SGI_make_current_read
> [  8581.437] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
> [  8581.437] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
> [  8581.437] (II) AIGLX: enabled GLX_SGIX_pbuffer
> [  8581.437] wglGetPixelFormatAttribivARB failed for WGL_NUMBER_PIXEL_FORMATS_ARB: Unknown error (c007000d (c007000d)
> [  8581.437] 0 fbConfigs
> [  8581.437] pxf vis  fb                      render         Ste                     aux    accum        MS    drawable             Group/
> [  8581.437] idx  ID  ID VisualType Depth Lvl RGB CI DB Swap reo  R  G  B  A   Z  S  buf AR AG AB AA  bufs num  W P Pb  Float Trans Caveat
> [  8581.437] -----------------------------------------------------------------------------------------------------------------------------
> [  8581.437] (II) AIGLX: Set GLX version to 1.3
> [  8581.437] (II) GLX: Initialized Win32 native WGL GL provider for screen 0
> When I try to run glx programs they don't work, and glxinfo gives me
> this error, regardless of whether I set LIBGL_ALWAYS_INDIRECT:
> Error: couldn't find RGB GLX visual or fbconfig

Thanks for trying it out.  I guess you win some kind of prize for being the
first person to report a bug in WGL mode :-)

It looks like we are failing to get a list of OpenGL visuals from the driver
for your graphics card, which will prevent OpenGL from working at all.  Not
sure if this is due to something XWin is doing wrong or your graphics card
driver not properly supporting the WGL_ARB_pixel_format extension.

I wish you'd attached the full log so I could see what had been reported for
GL_VERSION, GL_VENDOR and GL_RENDERER, as that would give me some idea what
graphics driver causes this bug to manifest.

Anyhow, can you try with 'GLWIN_NO_WGL_EXTENSIONS=1 XWin -wgl -multiwindow'
which will use DescribePixelFormat() rather than the WGL_ARB_pixel_format
extension and might work better?

Volunteer Cygwin/X X Server maintainer

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list