X server segfault problem

chm devel.chm.01@gmail.com
Mon Jan 3 17:55:00 GMT 2011

On 1/3/2011 11:55 AM, Jon TURNEY wrote:
> On 02/01/2011 01:11, chm wrote:
>> I'm having a problem with cygwin 1.7.7
>> and X version where an OpenGL
>> application from perl using the Mesa3D
>> binding dies in the test with a segfault:
> X related questions belong on the cygwin-xfree list.
>>    A fatal error has occurred and Cygwin/X
>>    will now exit.
>>    Caught signal 11 (Segmentation fault).
>>    Server aborting.
>>    Please open /var/log/xwin/XWin.0.log
>>    for more information.
>> When I close the popup alert, X exits.
>> The XWin.0.log only has Segmentation
>> fault at address 0xe.
>> I've been unable to determine if the
>> problem is in the perl OpenGL module
>> code or in the updated X+GLX+Mesa3D.
> Even incorrectly written X clients shouldn't make the X server crash, so if
> the X server crashes, it is an X server problem.
>> To reproduce, just download the perl
>> OpenGL module source:
>>    http://search.cpan.org/CPAN/authors/id/C/CH/CHM/OpenGL-0.64.tar.gz
>> and extract the directory.  cd to the
>> OpenGL-0.64 directory and run the following
>> command:
>>    ( set -x ; perl Makefile.PL ; make ; make test ) 2>&1 | tee
>> ../pogl-x-crash-log.txt
>> which should configure, build and run the test
>> for this module.  You will need to have gcc,
>> perl and opengl installed in your cygwin.
>> Any help appreciated since I can no longer
>> develop on cygwin since the X server started
>> crashing...not even to fix the problem (if
>> it is the OpenGL module code).
> This kind of implies it used to work, but doesn't tell me which version it
> worked with.

It worked with cygwin 1.5.25 and earlier.  The X that
came with the move to the 1.7.x series was the first
that had the crash.

> Anyhow, I've just fixed an OpenGL related problem which looks similar to this,
> perhaps you could try the snapshot in [1] and see if that helps.
> [1] http://cygwin.com/ml/cygwin-xfree/2011-01/msg00001.html

I assume this is a binary to replace the existing
XWin.exe....just ran the new XWin.20110102-git-29db9091c6ae4995.exe
and the server did not crash when I ran the test.  There was
a problem with a missing font so the text did not display but
I don't know if that was because I did not set something up
correctly in "just running" the XWin program by hand.


P.S.  This might bounce from the cygwin-xfree since I don't
know if I have sign up for that list.

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list