Emacs problems after dbus (?) update

Ken Brown kbrown@cornell.edu
Sat Dec 3 18:30:00 GMT 2011

On 12/3/2011 10:17 AM, Jim Reisert AD1C wrote:
> On Sat, Dec 3, 2011 at 4:42 AM, Ken Brown wrote:
>>> (emacs:3380): GLib-GObject-WARNING **: Two different plugins tried to
>>> register 'BasicEngineFc'.
>> Try removing /etc/pango/pango.modules .  See
>>   http://cygwin.com/ml/cygwin-xfree/2011-11/msg00047.html
> Ken, that did fix the problem.  Why did this just start happening
> (after the last update), and what's the long-term fix?  At least if it
> comes back, I know what to do.

This is just a minor glitch, related to the fact that Yaakov is 
gradually updating some packages that were updated long ago in Ports. 
[It's minor because emacs actually worked fine, in spite of all the 
warnings].  I'm sure he will get this all sorted out.

> I don't use Gnome - is there a way to uninstall the whole package,
> including Pango?

emacs-X11 is built using the gtk toolkit.  This is the upstream default 
for emacs, and I don't want to do something special for Cygwin unless 
there's a good reason.  So emacs-X11 requires libgtk, which requires 


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list