connection refused (errno 111): unable to connect to X server

Joshua J. Yi
Tue Aug 9 15:58:00 GMT 2011

Hi All,

I've been having this problem for a while now and I can't seem to figure 
out how to solve it. I've checked the FAQ, mailing lists, and done web 
searches, but unless I've missed something (quite possible!), the 
solution to my problem isn't out there.

When I run "startxwin" in the bash window, I get the following error:


giving up
startxwin:  Connection refused (errno 111):  unable to connect to X server
startxwin:  No such process (errno 3):  Server error


The error log (XWin.0.log) is attached.

For some reason, X doesn't start or isn't working. (Same result when I 
start from X from the start button.)

This has been an on-going problem for months now (been working on it 
intermittantly), and after multiple updates, so I don't think it's a 
package-version issue. Currently, I've installed every package in 
cygwin, but that doesn't help.

I haven't had problems installing cygwin in the past on different 
computers, so I wonder if it's a library problem (something) with this 
computer (a thinkpad).

Anyways, I'll apologize in advance if the solution is out there already, 
but after digging through the FAQ and mailing lists and trying various 
things, I'm at wit's end.

Also, thanks in advance.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: XWin.0.log
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list