Still can't run XServer or any apps that require it

Mon Apr 25 15:23:00 GMT 2011

On 23/04/2011 17:47, David M. Karr wrote:
> Almost a week ago now, I've been unable to run my XServer, and thus any of the
> apps that normally run with it, like Emacs.

I realise this situation is an inconvenience, but please don't post to
multiple lists just because you don't get a quick response.

> When I run "startxwin", it just
> says "failed to activate core devices".
> [498341.949] (EE) XKB: Could not invoke xkbcomp
> [498341.949] (EE) XKB: Couldn't compile keymap
> [498341.949] (EE) XKB: Failed to load keymap. Loading default keymap instead.
> [498342.089] (EE) XKB: Could not invoke xkbcomp
> [498342.089] (EE) XKB: Couldn't compile keymap
> [498342.089] XKB: Failed to compile keymap
> [498342.089] Keyboard initialization failed. This could be a missing or
> incorrect setup of xkeyboard-config.
> [498342.089] Fatal server error: Failed to activate core devices.
> ------------------------------
> I looked in the FAQ for the entry corresponding to this error, but none of the
> steps found any issues.  I've tried doing "rebaseall" according to the
> instructions, but that hasn't made any difference.  In fact, my problems
> started when I ran "rebaseall" to fix a different problem.  I was getting
> "Doing vfork: resource temporarily unavailable" when I started up Emacs, and
> some advice I found suggested running "rebaseall".

Unfortunately, rebaseall is a rather limited workaround, rather than a
solution for these issues (for reasons which have been discussed extensively
in the past)

There has been a recent cygwin DLL change which *might* help in this
situation, so I'd suggest you try the 2011-04-07 snapshot from [1] and see if
that makes a difference. (I wouldn't recommend later ones as they seem to have
a regression in a different area)


Volunteer Cygwin/X X Server maintainer

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list