Latest Cygwin X hangs when mouse is used to highlight text

Brian Kelly
Tue Sep 14 20:06:00 GMT 2010

Also - tried GVim, and it locked when I only got one character highlighted. Tried minTTY, and it works perfectly (of course it's not X-based). The cut-and-paste works flawlessly.

Again, why "X" highlighting and cut-and-paste worked yesterday and not today is the real mystery. The machine has been rebooted numerous times as well - to no avail.

Brian Kelly

-----Original Message-----
>From: Brian Kelly 
>Sent: Sep 14, 2010 2:52 PM

>Subject: Re: Latest Cygwin X hangs when mouse is used to highlight text
>Thanks Jon for the quick reply. I attached a new log file generated with an attempt to highlight - followed by the "hang".
>Again, this worked PERFECTLY just yesterday. I ran a chkdsk on my system just about an hour ago, and while it repaired a few files, the problem remains.
>I'll try your -noclipboard suggestion, but unfortunately for me, I do a lot of pasting back and forth between cygwin and native windows. I may have to go back to using the CMD based bash shell console window that is the cygwin default.
>Not relishing that thought ...
>Re-imaging my machine is not really an option either - that could set me back a "week".
>Brian Kelly
>-----Original Message-----
>>From: Jon TURNEY 
>>Sent: Sep 14, 2010 1:47 PM
>>Subject: Re: Latest Cygwin X hangs when mouse is used to highlight text
>>On 14/09/2010 18:51, Brian Kelly wrote:
>>> I've been using Cygwin X trouble-free for years, and am running the latest
>>> distribution of X and the Cygwin1.dll for at least two weeks (since the
>>> Cygwin release). It's been fine until this morning when it started
>>> locking on me whenever I used the mouse to highlight text. I have NO IDEA
>>> what changed on my system to now cause this behavior. **ANY** help you can
>>> give to assist me would be most appreciated since I use it for all my
>>> development efforts.
>>This is very likely to be some sort of problem with the clipboard integration 
>>You might find that using the '-noclipboard' option works around the problem 
>>(at the cost of not being able to cut/paste between Windows and X apps).
>>An xserver log with '-logverbose 3' might shed a bit more light on what's 
>>going on.
>>Volunteer Cygwin/X X Server maintainer

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list