No xauth program

Scott T. Marshall
Wed Sep 1 19:33:00 GMT 2010

Hi All,
I am struggling to get my ssh server to forward x windows. I have 
followed the cygwin documentation several times and cannot get my 
windows 7 (x64) machine to forward any x windows over ssh. This is 
particularly frustrating because I set this all up with no problem on my 
laptop which is also running windows 7 (x64). Here is my short 
description and info. Please let me know if I need to provide any extra 
info. I've done extensive web searches and searched the cygwin FAQ's and 
mailing lists, but can't seem to find a similar problem.

I have added "ForwardX11 yes" to /etc/ssh_config
I have added "X11Forwarding yes" to /etc/sshd_config
I have the XWin server running and am using xterm with the following 
command (on one line of course)
C:\cygwin\bin\run.exe -p /usr/X11R6/bin xterm -display -ls 
-g 115x35 +tb -fn 8x16 -sl 1000 -sb -rightbar -ms red -fg yellow -bg black

So, my xterm pops up just like normal and I can successfully ssh to 
localhost, but when I try to open something graphical (e.g xeyes or 
nedit) I get
Error: Cannot open display

when I connect using

ssh -Yv localhost

  the last few lines of output are:

debug1: Entering interactive session.
debug1: No xauth program.
Warning: No xauth data; using fake authentication data for X11 forwarding.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Remote: No xauth program; cannot forward with spoofing.
Last login: Wed Sep  1 15:03:40 2010 from ::1

I don't understand the No xauth program part. I have xauth in /bin
which xauth
and when I check the permissions on xauth, I see that they are 755 and I 
am the owner.

I even tried the suggestion that someone made on the listserv to add a 
line to ~/.ssh/config
and that didn't work, so I tried
and that didn't work either.

Does anyone have any ideas what is going on here? Any help would be very 
much appreciated.

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list