changing font

Thomas Dickey
Wed Sep 1 09:07:00 GMT 2010

On Tue, 31 Aug 2010, matias kaukonen wrote:

> Yes, it displays the font but it does not set the font.  Only the
> 'quit' button works.

I was asking about the result with xfd to be sure that the font itself is 
recognized.  I don't see anything wrong with the description of your 
changes to the X resources.

Another place to check is whether there are conflicting font resources 
shown, e.g., using "appres XTerm".

Beyond that, I generally just compile xterm with its debugging trace
enabled and see what resource value is actually used.  It's also possible
to get the nominal value of the font using an escape sequence in a script
or program such as xtermset.

> On Mon, Aug 30, 2010 at 4:22 PM, Thomas Dickey <> wrote:
>> On Mon, 30 Aug 2010, matias kaukonen wrote:
>>> The above worked on my previous computer, but now it does not work with my
>>> current computer.  This is what I tried:
>>> 1. a)  Added XTerm[.*]vt100.font:lucidasanstypewriter-10 to .Xdefaults
>>>   b) typed: xrdb ~/.Xdefaults; xrdb ~/.Xresources
>>> next,
>>> 2. a) Added XTerm[.*]vt100.font:lucidasanstypewriter-10 to .Xresources
>>>   b)  typed: xrdb ~/.Xdefaults; xrdb ~/.Xresources
>>> But neither one affected the xterm font.
>> does
>>        xfd -fn lucidasanstypewriter-10
>> display the font you asked for?

Thomas E. Dickey
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list