Failed to create /tmp/.X0.lock file?

Chris Fouts
Sun Oct 31 15:47:00 GMT 2010

On Thu, Oct 28, 2010 at 1:35 PM, Jon TURNEY <> wrote:
> On 28/10/2010 14:09, Chris Fouts wrote:
>> After power up, I log in on a Vista 32 machine on a non-admin account,
>> and start XWin server via power shell by calling the startxwin.exe
>> executable. Sometimes XWin fails to start and I get a pop up that says
>> (paraphrase) "Failed to create /tmp/.X0.lock file" I tried using the
>> -nolock option to no avail. How can I alleviate this? Thanks!
> Unfortunately, we have some bugs which prevent the X server from shutting
> down cleaning and removing it's lock file under some circumstances.  But
> that should only causing problems if you are non-admin and the previous run
> was under a different account, which doesn't seem to be what you are saying
> here?
> Are you sure you are supplying the -nolock option correctly? The syntax for
> adding it to the startmenu shortcut is unfortunately rather obscure, but [1]
> should explain it.
> Are you sure you get the same error message with -nolock?
>> Unsubscribe info:
>> Problem reports:
> If that doesn't help you resolve your problem, can you supply the additional
> information suggested by the problem report link above?
>> Documentation:
>> FAQ:         
> [1]
> --
> Volunteer Cygwin/X X Server maintainer

Thanks. I'm starting the XWin server in a PowerShell script, so I'm
figuring out now how to put the quotes after the -c option as
indicated in the help page.

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list