gvim tiny font in 1.7.7

David T-G d10@justpickone.org
Sat Oct 23 10:17:00 GMT 2010

Hi again, all --

I didn't hear any reply to my last note (or even see it posted), but in
case that one made it out and this one can as well, ...

...and then David T-G said...
% ...and then Jon TURNEY said...
% % 
% % Does 'xrdb -query | grep dpi' output anything?
% Alas, no; in fact, 
%   xrdb -query
% doesn't return anything at all.

I haven't loaded any Cygwin updates.  I haven't loaded any Windows
updates.  I still get nothing from xrdb.  I've rebooted more times
than I can remember.  I'm using the same user account.  As far as I
can tell, nothing has changed.

But suddenly it works!  After this morning's reboot, I was restarting
everything (always a chore under Windows *sigh*) and on a lark tried
gvim again.  I was floored to see it come up quite visibly, and even
with some font I didn't quite recognize.  Typing

  :set guifont

showed me that it was sans, which is interesting but probably came
from not being able to find Lucida Console on my machine.  I changed
my guifont line in my .vimrc file to Courier Bold and it worked just
fine.  I ripped it out entirely and I go tthe familiar gvim font.  I
played with the size in my guifont line and gvim behaved.  I selected
my font in gvim itself countless times and it behaved.  WTF?!?

I hate these kinds of errors because it's so incredibly hard to get a
real resolution to the problem, but I'll not turn down having my gvim
work again :-)

Thanks to all for trying to help!

David T-G
See http://justpickone.org/davidtg/email/
See http://justpickone.org/davidtg/tofu.txt

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin-xfree/attachments/20101023/070093b3/attachment.sig>

More information about the Cygwin-xfree mailing list