Updated: xorg-server-1.9.2-1

Jon TURNEY jon.turney@dronecode.org.uk
Wed Nov 10 16:25:00 GMT 2010

On 09/11/2010 09:02, Fergus wrote:
>>> Fatal server error:
>>> Can't read lock file /tmp/.X0-lock
>> Does /tmp/.X0-lock exists? Is it readable by you?
> Yes.

Hmm. It's strange that the Xserver should choose to lie about that, then.

The code in question really does just say...

      lfd = open(LockFile, O_RDONLY);
      if (lfd < 0) {
        FatalError("Can't read lock file %s\n", LockFile);

... so I can't see much room for unpredictability.

It would be helpful if you could strace XWin to see why it gets this wrong.

Have you tried manually removing the lock file /tmp/.X0-lock?

>> Are you sure /tmp is getting mounted successfully
>> where you expect it to be?
> Yes.
>> Have you tried '-nolock', as suggested by [1]
> I hadn't then.
> But I have now and as a consequence everything is working perfectly.
> Thank you.
> (Over time I have occasionally had to moderate the syntax of both "XWin" and
> "xterm" command lines to go from working to failing and back again to working.
> This is just another example. On an earlier occasion, the recommended use of
> -nolock failed. I am just happy when the current usage works. Thanks again.)

Well, I can't deny this might be your experience, but that's not how things
are supposed to work :-)

Volunteer Cygwin/X X Server maintainer

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list