Xwin SIGSEGV when font server should be queried

Jon TURNEY jon.turney@dronecode.org.uk
Fri Nov 5 19:52:00 GMT 2010

Thanks for reporting this issue.

On 04/11/2010 14:49, Weeber, Burkhard wrote:
> I updated my Cygwin with the latest available from the "setup.exe".

Do you know which version of Xserver that worked you updated from?

Examining /var/log/setup.log and/or using setup to revert to the previous
version should tell you.

> Now XWin.exe gets a Signal 11 (Segmentation violation) when a font switch (-fn) is on the command line.
> Command:
> $ ssh -Y myaix "aixterm -fullcursor -geometry 81x30-125+93 -e /usr/local/bin/max.pl"
> Is OK.
> $ ssh -Y myaix "aixterm -fullcursor -geometry 81x30-125+93 -fn 6x10 -e /usr/local/bin/max.pl"
> Fails.
> I have a font server running on AIX6.1 and before the start this font server is added by xset command.
> This worked well until the update.
> Also the xlsfonts command of cygwin distribution causes XWin to SIGSEGV.
> Also when specifying "-fp tcp/myfontserver:7100" on the XWin start line any X-Program will cause a SIGSEGV.

I'm afraid I'm not able to reproduce this (testing using an xfs running on
Solaris, I don't have access to AIX).

Can you please obtain a backtrace as follows:
1) Install gdb (for gdb) and sysvinit (for pidof) packages
2) Start XWin using your normal method
3) In a non-X terminal window, run gdb --pid=`pidof /usr/bin/XWin`
4) Type 'c' at the '(gdb)' prompt
5) Reproduce your crash
6) Type 'bt full' at the '(gdb)' prompt.

Volunteer Cygwin/X X Server maintainer

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

More information about the Cygwin-xfree mailing list