startxwin/XWin won't start properly

Larry Hall (Cygwin X)
Tue Jun 29 22:39:00 GMT 2010

On 6/29/2010 10:50 AM, Bradley, Mike wrote:
> Hi,
> All was good, till a couple weeks ago when I added some packages to cygwin,
> and several packages where also upgraded.  Then xterm response time became
> very slow.  I tried a second upgrade yesterday, and now I cannot even start
> an xterm, nor will startxwin start properly.  This is a company computer
> which has Symantec anti-virus.  I tried disabling that as well.
> Here is the most obvious symptom:
> % echo $DISPLAY % /usr/bin/startxwin.exe
> waiting for X server to begin accepting connections . .. giving up.
> /usr/bin/startxwin:  Socket type not supported (errno 124):  unable to
> connect to X server /usr/bin/startxwin:  No such process (errno 3):  Server
> error.
> Notice the value of $DISPLAY above, which does not match whats in XWin.0.log
> (it has :0.0).  No idea how/why that happens.

Remove the DISPLAY setting.  Update your installation (your cygwin package is
out-of-date).  You also have a couple of orphaned installations of Cygwin.
Make sure those are all cleaned up/out.

Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
216 Dalton Rd.                          (508) 893-9889 - FAX
Holliston, MA 01746


A: Yes.
> Q: Are you sure?
>> A: Because it reverses the logical flow of conversation.
>>> Q: Why is top posting annoying in email?

Unsubscribe info:
Problem reports:

More information about the Cygwin-xfree mailing list